yegg
Thx--I noticed this as well and reported it to Zoho. They are now in the process of getting me a valid certificate that should make it all work. In the mean time, don't check that secure checkbox.

If you do check it and you get the weird # error, just change the url to get rid of the s in https, i.e. to http://duck.co/
posted by yegg Staff7 years and 11 months ago Link