anonymous
What files do you have in /usr/lib/firefox/distribution/searchplugins/locale/*language* ?
posted by <hidden> • 4 years and 24 days ago Link

anonymous
$ ls en-US
Code:
amazondotcom.xml
bing.xml
duckduckgo.xml
eBay.xml
google.xml
twitter.xml
wikipedia.xml
yahoo.xml

$ ls fr
Code:
amazon-france.xml
bing.xml
cnrtl-tlfi-fr.xml
duckduckgo.xml
eBay-france.xml
google.xml
wikipedia-fr.xml
yahoo-france.xml


I'm using Ubuntu in English, but my country, keyboard, dates, etc. are in French.
I tried removing duckduckgo.xml from those directories, but I still can't add the search engine.
posted by <hidden> • 4 years and 23 days ago Link
anonymous
Try replacing the entire code in another search engine file, eg.bing.xml, with the one present in duckduckgo.xml, does it fix it? That would be an odd workaround, I know.
Or just backup your settings and create another FF profile ("firefox -P" in terminal).
Anyway the solution is probably easy but I don't know where that info could be stored, maybe asking in mozilla forum is the best help.
posted by <hidden> • 4 years and 23 days ago Link
anonymous
Have you tried the Firefox plug-in “Add to Search Bar”?

Saves messing around with xml files and always works for me. It even allows me to add DDG serveral times. I've done it by accident and with different regions.

1. Add the Firefox plug-in “Add to Search Bar”
2. go to https://duckduckgo.com/settings
3. set your region, language and other preference
4. click “Bookmarklet and settings data” at bottom of the page
5. click the long URL revealed by the bookmarklet
6. right click the DDG search dialog box and select “Add to Search Bar...”

If you set your theme before you set your region the URL link will also rest your theme.

So not only will this set DDG as your default search engine in Firefox but it will remember your settings even if you delete your cookies.

Terry
posted by <hidden> • 4 years and 23 days ago Link
anonymous
Hey!
This worked! Thanks a lot for pointing out this add-on!
Now I have working fine. This is great!
posted by <hidden> • 4 years and 4 days ago Link
anonymous
> 6. right click the DDG search dialog box and select “Add to Search Bar...”

I'm having exact same problem :/

However it looks like DDG removed opensearch funcionality as mentioned above and the only way to add it is to install extension?! :/
posted by <hidden> • 1 year and 7 months ago Link
x.15a2
Please reference my answer in your other post.
posted by x.15a2 Community Leader1 year and 7 months ago Link