tagawa
As x.15a2 says, it could be that your browsing history is being saved (default behaviour). Other things could be search suggestions, which can be turned off in Firefox in Preferences -> Search.

Also, it might help to switch off search queries displaying in URLs by going to DuckDuckGo advanced settings -> Privacy -> Requests shown in url (turn off and save). Note that this only affects searches made from the DuckDuckGo website - not searches from the browser address bar or search bar.
posted by tagawa Staff3 years and 5 months ago Link