MyUser
Try doing a hard reload (clicking the reload button in the URL bar or pressing F5). If the problem persists, delete your cache and try again. Likely the old version of DDG's script is still in your cache and you haven't gotten the fix yet.
posted by MyUser 3 years and 1 month ago Link

anonymous
Thanks for the suggestion.
Still dealing with the same problem though. I actually clear my cache every other day to keep things running smoothly and DDG is my homepage so I visit it more than any other site so I've refreshed probably thousands of times since my last post here. I just tried disabling all of my firefox extensions (no script[DGG is set to fully allowed anyway], ad block plus, redirect bypasser, etc...) to no avail. The original problem persist. However I've basically trained muscle memory to right click paste instead of first left clicking the search bar thus avoiding the drop down menu when pasting. Sometimes I still left click first and it's very annoying when hover select suggest occurs.

Hopefully a 'disable hover selection from the drop down suggestion menu' will be added as an option in advanced settings in the future. I still use the drop down menu to speed up searching but click to select would be much less annoying. For now I'll just deal with it as I have been.
posted by <hidden> • 3 years and 1 month ago Link