still can't save settings

<hidden> anonymous
Created: 3 years and 4 months ago • Updated: 3 years and 4 months ago
I've tried everything (I think) but still can't save my settings. Cookies are deleted upon closing DDG. I am running Ghostery.
Not choosing to use the "cloud" option, I tried these instructions found on this forum:

DDG-engine URL parameters
- settings are appended onto the DDG-engine URL as codes
eg, kaa=p&ku=1&kn=-1 in https://duckduckgo.com/?kaa=p&ku=1&kn=-1
- the pre-assembled compound URL can be copied directly from the Settings page in [Bookmarklets and settings data] link (very small link at bottom left of the Settings (dialog)
- copied coded-URL is then used as the DDG-engine opener (URL)

It doesn't work for me. My settings preferences revert to default every time I open a new session of DDG, even via the bookmarked URL!

Any thoughts or referral to another post I may have missed? Please be patient as I have little tech knowledge.

Thank you all

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.


anonymous
Is DDG your current homepage?
If you set the homepage in the browser's settings, write there the full URL with params, eg. https://duckduckgo.com/?kaa=p&ku=1&kn=-1
posted by <hidden> • 3 years and 4 months ago Link
anonymous
Yes, DDG is my homepage. Homepage is set in the browser settings but changes every time DDG is closed.
posted by <hidden> • 3 years and 4 months ago Link
anonymous
This is not a normal behaviour and DDG can't change browser settings without user choice. Check your browser and computer.
posted by <hidden> • 3 years and 4 months ago Link
anonymous
I have no answer. I dealt with the same problem as others I've talked with.
I just quit using DDG as a result. It just got too frustrating.
posted by <hidden> • 3 years and 4 months ago Link
Jlg
I would suggest turning off Ghostery permanently whilst using DDG. We don't support the add on's you use but suggest you check out the Ghostery add on website. Which is you weren't already very aware is

I use an add on in which I have to just restart Firefox and I'm good to go again. (after disabling it).

I hope this helps.

--jlg
posted by Jlg Community Leader3 years and 4 months ago Link
WingTillDie
The settings page is displaying the settings that your cookies set,which might be default setting
If you append your parameter,it will override the setting of cookies when you searching but the setting page is unchaged
So it's okay to saw that the settings in setting page is unchanged,your url parameter will overrite and take effect but not change the settings page
posted by WingTillDie 3 years and 4 months ago Link
anonymous
Interesting. So, it may only "appear" to be default settings when, actually, the changed settings I desire are being used? Any way to confirm that? Thanks
posted by <hidden> • 3 years and 4 months ago Link
WingTillDie
Choose a theme that different then the theme in settings
Append theme parameter in your url parameter
Then enter settings,you can see nothing in setings changes

I use terminal theme for my firefox search engine
But i've never change settings
So if I type ddg.gg in url
The theme is default
But if I enter
ddg.gg/?kae=t
The theme terminal activated
But if I click appearence setting
You can the theme is default
posted by WingTillDie 3 years and 4 months ago Link
anonymous
Sorry, WingTillDie, I don't understand what you are trying to say.
posted by <hidden> • 3 years and 4 months ago Link
zac
I think they're trying to clarify if you copied the settings URL after you changed your settings or before. I'm not quite sure, though.
posted by zac Staff3 years and 4 months ago Link
anonymous
.
posted by <hidden> • 3 years and 4 months ago Link
anonymous
oops....

Can't fix this problem. None of the suggestions (thank you all for trying!) work for me. I'll have to look at other options. Too bad, DDG was working well for me until the latest "upgrades." Oh well, same old story - it ain't broke but it needs to be fixed, anyway. The product may be fresher, but it's no better.
posted by <hidden> • 3 years and 4 months ago Link
DEADTOAST
Me too. I was trying to save the configuration without success. To achieve this, try what I did, maybe it will solve.

In Firefox open Tools, Options, General tab.

Enter on homepage: https://duckduckgo.com

On the Privacy tab locate the Exceptions box, and once inside, add the address: duckduckgo.com and hit allow.

Make sure you have checked the box: accept cookies.

Now enter in the box: Show Cookies, and delete them all.

Now select (check) the box: Clear history when Firefox closes
In the configuration box, next. Be sure to uncheck the boxes of cookies and site preferences to avoid being deleted.
Accept.

Now go to the settings page DuckDuckGo, and then reset.

Reconfigure DuckDuckGo page to your liking, and make a save and exit. Forget the Cloud.

In Firefox, return back to Tools, Options, Privacy. Once there, turn off the box to accept cookies.

The settings should not be deleted now, and you have more control over cookies, through the Exceptions box.
(Add here the most common or important pages for you to avoid problems.)
Remember that some cleaning programs like CCleaner, addons controlling cookies and some antivirus can remove these stored cookies. Check the settings of these programs.

I'm not sure if that was what solved my problem. I hope you have luck like me and ... happy Ducking.
posted by DEADTOAST 3 years and 4 months ago Link