Problem with security certificates on ¨This connection is untrusted¨How to fix it?

<hidden> anonymous
Created: 3 years and 11 months ago • Updated: 3 years and 11 months ago

I had a prob with the security certificates' configuration at firefox a few days ago. Since then, I can not access normally at duckduckgo, every time that I attempt to use it a warning appears" This connection is untrusted". If I choose the "add exception" option a message says that this site attempts to identify itself with invalid information". I can not select the "permanently store this exception" either and it is not possible to export the certificate and import it later because a password is required. How can I fix this problem?

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.

I had this briefly with yesterday but it works now and is fine.

You could try re-installing the relevant certificates which are issued by DigiCert and available here:

Click on the "Secure Server CA" and "Global Root CA" links and download the PEM files. If they're not already installed you'll get a dialog box prompting you to install. For trust, the three checkboxes should be all checked for the "Global Root CA" certificate and all unchecked for the "Secure Server CA" certificate.

Alternatively go to Preferences -> Advanced -> Certificates -> View Certificates -> find the DigiCert section. You could try editing or deleting/importing the "Global Root CA" and "Secure Server CA" certificates as above.

posted by tagawa Staff3 years and 11 months ago Link
posted by <hidden> • 3 years and 11 months ago Link