This Connection is Untrusted

<hidden> anonymous
Created: 3 years and 10 months ago • Updated: 3 years and 10 months ago
So what, do tell, is the Blessed Event that has recently caused DuckDuckGo to show up as an "untrusted connection" in Firefox? Have been searching all over the www and, frankly, someone says this and someone says that and someone says something else ... and I'm just too simple to ferret out a solution from all those discussions. And, further, I have not come up with any acceptable reason why I should spend seemingly endless on-line time trying to fix stuff like this. Perhaps there are those out there who find deep, deep satisfaction in being faced with the sudden appearance (after months and months of satisfactory use of DuckDuckGo with no problem whatever) of an error message such as this and relish the challenge of solving the issue(s). I am not one of that crowd. If a program doesn't do what it's supposed to, I'm done with it. That said, I would prefer to use DuckDuckGo as my default, but with a needless annoyance such as this "untrusted connection" business, I'm back to Bingland.

Any solutions?


This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.

No, not Bingland!

It sounds like your issue is similar to this:

so the instructions in the reply there might help. Please let us know if it works (or not).
posted by tagawa Staff3 years and 10 months ago Link
Thanks for the info. I went to:

You could try re-installing the relevant certificates which are issued by DigiCert and available here:

Click on the "Secure Server CA" and "Global Root CA" links and download the PEM files. If they're not already installed you'll get a dialog box prompting you to install. For trust, the three checkboxes should be all checked for the "Global Root CA" certificate and all unchecked for the "Secure Server CA" certificate.

Alternatively go to Preferences -> Advanced -> Certificates -> View Certificates -> find the DigiCert section. You could try editing or deleting/importing the "Global Root CA" and "Secure Server CA" certificates as above.

1) Doing the first part ("Click on ... download PEM ... etc:") results in "This Certificate is Already Installed as a Certificate Authority";
2) Doing the second part ("Alternatively...."), shall I assume that when you say "try editing" you mean that if some boxes are unchecked that I should check them? That is what I did for "Global Root CA" and "Secure Server CA".

DuckDuckGo seems now to open OK.

I have Bitdefender onboard and when I would "view certificate" before, at the "Could not verify this certificate because the issuer is unknown", under
"Issued by" it would indicate "Common Name (CN): Untrusted Bitdefender CA"
and under
"Organization (O): Bitdefender" ....

Contacting Bitdefender, they directed me to basically remove all of their protection step by step and see if anything changed; nothing did: now, having done the editing as you recommended, I went back through that deletion process in Bitdefender and it appears that unchecking "Web Protection: Scan SSL" solves the problem .... at least for tonight.

Thanks for your assistance. Appreciated.
posted by <hidden> • 3 years and 10 months ago Link
Round III:

Well, crap. Seemed to work until I closed Firefox and reopened the browser: then I was right back to where this whole business started ....

"Untrusted connection" with
Issued by:
"Common Name (CN): Untrusted Bitdefender CA"
"Organization (O): Bitdefender"

Then I have to go through the "View Certificate" and so the "exemption" business all over.

NOT ACCEPTABLE! I am uninterested in spending my on-line time jumping through techie hoops.

So what is the reason that after I do all noted above, what with the editing, the whole process just reverts to where it was when I started this ridiculous solution-chase?

posted by <hidden> • 3 years and 10 months ago Link