Auto-Suggest drop down menu click select instead of hover select.

<hidden> anonymous
Created: 2 years and 10 months ago • Updated: 2 years and 10 months ago
Hi, I'm having a problem with auto-suggest. I'm aware I can disable it but would rather not as I use it a lot. My problem is when I want to right-click and paste into the search bar auto-suggest automatically adds whatever word (suggestion) is under my mouse after clicking paste to the search bar. Basically it's hover selecting from the auto-suggest drop down menu and I'd like it to be click to select. That way I can paste from my context menu (right-click paste) without auto-suggest auto adding/changing what's in the search bar.

I can just CTRL+V or right-click the search bar to paste, but if I first left click to select the search bar then right click second, when I click paste it hover selects from the drop down suggestion menu. Clicking to select instead of auto hover selecting would fix this issue.
Attached Files: 1
example.gif - Full

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.


anonymous
I just noticed this issue, and I would agree that it badly needs to be fixed. If the mouse happens to be in the wrong place when typing in a search request, I end up with a long sequence of words, which I then can't get rid of without moving the mouse off the drop-down. So I'll type in, say, 'aspectj' and instead it will search for 'american airlines phone number phoenix college times journal.'

I don't want to have to think about where the mouse pointer is before typing in a request.
posted by <hidden> • 2 years and 10 months ago Link
andrey_p
Hi, thanks for reporting that issue. We pushed out a fix for it yesterday, but do let us know if you're still seeing any problems.

Andrey
posted by andrey_p Staff2 years and 10 months ago Link
anonymous
Thanks, but I'm still having the same issue as my original post shown in the gif I attached. Also, what the first commenter mentioned is still a problem. This may be duckduckgo blasphemy to say this but google although I rarely use it has this problem sorted, with left click to select from the drop down menu instead of hover select. An option under 'auto-suggest' in the advanced settings menu to turn off hover select would be great. Thank you for your time and quick response in this matter.
posted by <hidden> • 2 years and 10 months ago Link
MyUser
Try doing a hard reload (clicking the reload button in the URL bar or pressing F5). If the problem persists, delete your cache and try again. Likely the old version of DDG's script is still in your cache and you haven't gotten the fix yet.
posted by MyUser 2 years and 10 months ago Link
anonymous
Thanks for the suggestion.
Still dealing with the same problem though. I actually clear my cache every other day to keep things running smoothly and DDG is my homepage so I visit it more than any other site so I've refreshed probably thousands of times since my last post here. I just tried disabling all of my firefox extensions (no script[DGG is set to fully allowed anyway], ad block plus, redirect bypasser, etc...) to no avail. The original problem persist. However I've basically trained muscle memory to right click paste instead of first left clicking the search bar thus avoiding the drop down menu when pasting. Sometimes I still left click first and it's very annoying when hover select suggest occurs.

Hopefully a 'disable hover selection from the drop down suggestion menu' will be added as an option in advanced settings in the future. I still use the drop down menu to speed up searching but click to select would be much less annoying. For now I'll just deal with it as I have been.
posted by <hidden> • 2 years and 9 months ago Link