Problem with Adjusting the Alignment and Header Behaviour in the Settings

Tharthan Tharthan
Created: 3 years and 2 months ago • Updated: 3 years and 2 months ago
Turning Centre Alignment off and setting the header behaviour to be on & scrolling or to be off do nothing after saving, and instead reset to being centre aligned and on and floating.

If it matters, I am using the Pale Moon browser on the Windows 7 operating system.

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.


x.15a2
Thanks for your post. I want to make sure that I'm able to follow and would like some add'l information. I just checked and the default for Center Alignment is OFF and Header Behavior is ON AND SCROLLING (that is when using the Default theme).

Can you please let us know which theme you are using, which browser you are using and any significant add-ons that you use with the browser (especially any that control cookies). One method of saving settings is via cookies and since you are unable to reset to default settings, I'm wondering if you have something that keeps some cookies from being updated... just a thought.

Thanks!
posted by x.15a2 Community Leader3 years and 2 months ago Link
Tharthan
I am using the "classic" theme.

I had cleared my cache and my cookies completely before I tried changing the settings today.

The first thing that I changed, if I recall correctly, was the theme to the "classic" theme. Then I changed all of the other advanced settings.

And, yes, I do have the settings saved via cookies.

I am using Pale Moon Version: 25.6.0 (x86) as my browser for Windows 7.

These are all of my add-ons:

Adblock Latitude 3.0.2

Adblock Plus Pop-up Addon 0.9.2.1-signed

BetterPrivacy 1.68.1-signed

Blur (Formerly DoNotTrackMe) 4.5.1334.1-signed

DuckDuckGo Plus 0.4.2.1-signed

Encrypted Web 5.0.9

Flagfox 5.1.2

Greasemonkey 3.2
(for which I only have one script; for a site called "KeepVid".)

Hotmail Watcher 2.28

Pale Moon Commander 1.7.1

Procon Latte Content Filter 3.3.01.1-signed

View Cookies 1.12.1-signed
posted by Tharthan 3 years and 2 months ago Link
x.15a2
I too use Pale Moon as my primary browser, I'm on the same version as you. I just tested using "Retro" theme and replicated what you are seeing. I will report this to the devs, I wonder if that is just part of the theme, but if that's the case it seems that the setting wouldn't be available.

Just to verify, try going to the default theme and using the settings that you prefer, just to verify. I'm not suggesting this as a fix or work-around, just to verify that your cookies are set.

I'll report back if I hear from the devs.

Thanks!
posted by x.15a2 Community Leader3 years and 2 months ago Link
Tharthan
I did what you asked: I changed the theme to the default one, and then made the same specifications as I had before (except that I didn't have to set the centre align to "off" and the header behaviour to "on and scrolling". It saved and works fine, but I changed it back because I prefer the "classic" theme modified the way that I had it set.

Even if that were the case, why would it need to be part of the theme? Why can't it be toggled on and off and changed around a bit? When one is still on the configuration page, it applies the changes perfectly well until one clicks "save", return to DuckDuckGo's homepage, and then actually try and put the changes into action.

I actually don't mind Duck Duck Go's look with the classic theme and the settings that I applied.

If I could adjust the centre align to be "off" and the header behaviour to on and "on and scrolling", it would have a fairly solid look in my eyes, personally.
posted by Tharthan 3 years and 2 months ago Link
x.15a2
I just did a quick search ( https://duck.co/forum/search?q=retro )and found that this is a known issue and the developers are aware of it ( https://duck.co/forum/comment/59140 ). Sorry, I don't a have a more current status.
posted by x.15a2 Community Leader3 years and 2 months ago Link
Tharthan
Oh no, that's perfectly all right.

I'm just happy that it is being taken care of.
posted by Tharthan 3 years and 2 months ago Link
anonymous
I had trouble with the centre align myself after turning on. After adjusting many settings the centre align kept going to on even after resetting to off and saving. Had to reset all changes to default and not touch it again. Only tried once on IE so far and not a cloud user.
Did notice I have to save settings x2 for changes to save properly, not sure why. 1st save just takes me to top off page and keeps turning centre align on, once it`s on??
Running 360TotalSecurity but that stayed quiet during all changes which was nice.
posted by <hidden> • 3 years and 2 months ago Link
brians
We just released a bug fix for the center/header settings not working correctly with some Themes. I think it might resolve your issue. Can you check and let me know if you still experience any issues?

You will need to go to the Settings page and update the settings once again for the changes to stick.

Thanks!
Brian
posted by brians Staff3 years and 1 month ago Link
Tharthan
Hey, thanks fellas! It works now.

I really appreciate it! Thanks for fixing that.
posted by Tharthan 3 years and 1 month ago Link
brians
Awesome, glad to hear it! Keep submitting any issues you find, it really helps.
posted by brians Staff3 years and 1 month ago Link