android duckduckgo WebRTC leak

<hidden> anonymous
Created: 2 years and 11 months ago • Updated: 2 years and 11 months ago
can you fix this when im using a vpn on my android and i use the duckduckgo app and i go to ipleak.net i can see my ip address even though im using a vpn, firefox has this option where i can disable webrtc on android please make this available then ill reinstall your app

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.


MrSherlockHolmes
Please put this in "general ramblings".
posted by MrSherlockHolmes 2 years and 11 months ago Link
Moollaza
I've migrated this post to the General Ramblings section. Thanks for the head's up!
posted by Moollaza Staff2 years and 11 months ago Link
MrSherlockHolmes
Welcome! :P
posted by MrSherlockHolmes 2 years and 11 months ago Link
anonymous
Unluckily there seems to be no easy way to disable WebRTC from the WebView at least that I could find so far.
The flags available in Chromium to disable/enable webrtc adn other services are not available at webview level, or at least I can't seem to find a way to run them, if anybody has any idea how to, it would be nice.
I assume at some point the WebView will be upgraded to fix this, that was one of the point to the switch to chromium and to have it upgradable.

One solution I guess it could be to disable Javascript, and the ip leak should stop, the version on github now has the setting to disable it:
https://github.com/duckduckgo/android

Eventually we could migrate to Gecko instead of using the webview, but that would make the app size 3/4 times bigger
posted by <hidden> • 2 years and 11 months ago Link