Search using Copy & Paste

<hidden> anonymous
Created: 2 years and 2 months ago • Updated: 2 years and 2 months ago
This has been asked before:
When you type a word in Search Bar & want to add a "Copy & Paste" to it, you CANNOT do it?????
WHY?
When you click to post the Copy & Paste, it adds one of the DuckDuck suggestions in the Search Bar
It will NOT let you add the (click) Copy & Paste
This REALLY sux.............
You have to type in what ever you want to add.
.
IF you start with a clean Search Bar, you can (click) in the Copy & Paste
.
Google does not have that issue.............

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.


x.15a2
I'll give the devs a bump on this issue. In the mean-time, I've found that you can use Ctrl-Insert or Ctrl-V to paste the copied text.

Thanks
posted by x.15a2 Community Leader2 years and 2 months ago Link
This comment has been removed for violation of our forum rules.
posted by <hidden> • 2 years and 2 months ago
anonymous
I am getting annoyed having to type in info, when other search sites lets you copy & paste for the sake of time & mistakes.
DuckDuck has that pop up, which keeps you from adding to or inserting a copy & paste, without typing it in.
Cannot believe it is not a problem for other users
I would add a attachment, but there is NO way that I see in this post
http://wikisend.com/download/353166/chro...
posted by <hidden> • 2 years and 1 month ago Link
zac
what browser is this happening on?
posted by zac Staff2 years and 1 month ago Link
anonymous
I.E. 11.0.9
FF 41.0.2
has been this way for at least a year
seems like it should be a simple fix, as I hate google
posted by <hidden> • 2 years and 1 month ago Link
x.15a2
A potential work-around (not meant as a fix and not to diminish the point of this topic) is to disable Auto-Suggest in Settings, or use the bookmarklet: https://duckduckgo.com/?kac=-1
posted by x.15a2 Community Leader2 years and 1 month ago Link
anonymous
I guess it is me, as I have not seen anyone else ask about the issue..........
Thanks for the response
posted by <hidden> • 2 years and 1 month ago Link
zac
This should be fixed now -- can you verify?
posted by zac Staff2 years and 1 month ago Link
anonymous
nope........still does exactly the same
verified with I.E. 11 & FireFox
.
Have 3 images the show the 3 steps to Copy & Paste, but have no way to post them in this response
.
Type or Copy & Paste into "blank" DD Search Bar
If you want to add more info using Copy & Paste, it brings the small drop window down that shows DD search info.
Then if you want to Paste more info that is already in the Search Bar, right click, which brings down the "Paste" window.
Click Paste (or any of the other items) & what ever DD search info is showing in the first drop down "next to" the Paste word (or any of the other items) will make the DD search info appear in the Search Bar & NOT what you wanted to paste.
posted by <hidden> • 2 years and 1 month ago Link
thobby
I'm just checking because I was have issues with the drop down suggestions before - after you take your cursor down to the paste option is your cursor moving/hovering over the suggestion part at all? Because as soon as the cursor touches any part of the suggestion it automatically fills the suggestion into your search bar. (Instead of the "paste" words)
I was doing this before without realizing it. I just tried what I think you are saying and I was able to insert the copy/paste words successfully as long as I didn't move my cursor onto the suggestion portion.
Also, you can turn off the suggestion function altogether but you may like to keep it. Sorry if I've misunderstood any of your issue.
posted by thobby 2 years and 1 month ago Link
thobby
having*
posted by thobby 2 years and 1 month ago Link
anonymous
thank you for the response..........
I would like to post the 3 examples here, but there is no way to insert it into this post.
When I "first" put the cursor into the Search Bar, I click "paste", which requires one to move the cursor down to the word "paste"........
That part works fine
IF I type a word in first or Paste a word in first, then want to add a "Copy & Paste", that is when the "suggestion box" appears & one "cannot" add the Copy & Paste into the Search string, as when you move the cursor down to "paste", it pastes what ever the word / suggestion is in the suggestion box that the word "paste" is on...........
posted by <hidden> • 2 years and 1 month ago Link
x.15a2
Quote:
I would like to post the 3 examples here, but there is no way to insert it into this post.


Sure you can. Just post your image to an image hosting service, then use the Add an Image button. (The following is not an endorsement, it's a brief tutorial for posting images in replies): I use http://snag.gy/, which makes uploading and attaching images very easy. All you need to do is copy the local image to your clipboard then paste it into snag.gy and copy the provided link. Give it a try!
posted by x.15a2 Community Leader2 years and 1 month ago Link
anonymous
http://snag.gy/qCvZS.jpg
.
http://snag.gy/Uz2iq.jpg
.
http://snag.gy/Q293n.jpg
.
Hope I did that right............
Shown is Copy & Paste (1)
Then when I go to Copy & Paste another the drop down for "paste" (2) picks up the words "New notifications on facebook"..........
posted by <hidden> • 2 years and 1 month ago Link
x.15a2
I tested using current versions of IE, FF, Chrome and Pale Moon and I am unable to replicate what you are seeing. In fact, the only time that the autosuggest answers appear in the search bar is when I mouse over them (which is correct functionality). As long as my cursor is in the search field, pasting works as expected.

I suppose that this could be a caching issue, you may want the follow your browser's documentation for clearing your cache. Sorry, I can't duplicate this, so I can't think of any other cause of the issue. Maybe someone else from the community can offer a solution.
posted by x.15a2 Community Leader2 years and 1 month ago Link
thobby
On your examples where is your cursor? I also tried to replicate what you are experiencing on Firefox and IE and Pale Moon and as long as my cursor stays in the cut/paste box and not onto the suggestions (even after you click paste-make sure your cursor is not touching suggestions) then it pastes the appropriate word. It almost sounds like your cursor is not recognizing the cut/paste box and clicking on the auto suggest though I've no idea why that would happen. Are you using your cursor to click paste or are you using the arrow keys and enter to select paste? I guess I've reached the end of my knowledge to help. Especially as it is happening with 2 different browsers. I'd say reload the browser (saving your bookmarks, etc) but if it's on both FF and IE then I'm mystified.
posted by thobby 2 years and 1 month ago Link
anonymous
It works for me, i'm on a mac.
posted by <hidden> • 2 years and 1 month ago Link