Stop Correcting Me

<hidden> anonymous
Created: 3 years and 2 months ago • Updated: 3 years and 2 months ago
There needs to be a way to completely and permanently disable all spelling correction, stemming, synonyms, suggestions, and so forth -- something like Google's "Verbatim" sense, only better because it would actually work and could be made the default. There may be reasons why I'm searching on a misspelled word or bizarre phrase, and it's extremely annoying when the search engine "corrects" my search for me. Just return the %$(*@%^ results for my search terms, thank you!

And no, enclosing the word or phrase in quotation marks does not always work. In fact, I'd say it works less than half the time. It also seems to ignore punctuation, which may also be part of my search (for example, searching for a particular file, including its extension).

Frankly, I hate all search corrections and suggestions. I think they're just another symptom of the dumbing down of society. It's search for idiots who can't spell and don't know to identify the salient keywords in an idea to search on them. If you must lower the bar to embrace idiots, at least provide a way for those of us who aren't illiterates to shuck off the training wheels, search intelligently, and receive unfiltered results for what we actually searched on. Maybe a dedicated subdomain like "" would work.

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.

its ok. You can mention it at
posted by duckduckian 3 years and 2 months ago Link
also you could issue it on github...
posted by duckduckian 3 years and 2 months ago Link
I concur. I often search things with unusual spellings, and it makes me nuts when I get "corrected" to a wrong spelling endlessly. Today, looking for "jo daviess" a county in Illinois, it changed the second word to "advises" numerous times, even when I went back to "uncorrect it" It did it again in this post, and also "fixed the word "uncorrect" to "incorrect" both times. PLEASE give us a reliable way to turn the spell check OFF!
posted by <hidden> • 2 years and 3 months ago Link
That's interesting, because I just did the search that you suggested and only got "jo deviess" in my results, and no request for a spelling correction:


The reliable way of disabling spell checking is to use the Limit results to xxx option when spelling suggestions are presented.

posted by x.15a2 Community Leader2 years and 3 months ago Link