DDG as firefox search engine, cannot install

<hidden> anonymous
Created: 1 year and 6 months ago • Updated: 1 year and 6 months ago
Hi,
Firefox ESSR 45.4.0, Win7. while trying to add ddg as firefox search engine I get the followign error:
[IMG]http://pics.tinypic.pl/i/00849/6rqnypsksj8z_t.jpg[/IMG]

"restore default search engine" button is grey out,

any suggestions ?

Thanks

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.


x.15a2
The Restore button is probably disabled because no changes have been made from the default settings. From this screen you should be able to select DDG as your default search engine and you're all set to go.
posted by x.15a2 Community Leader1 year and 6 months ago Link
anonymous
c'mon, i've changed there whatever is possible and its all the time grayed out.

there has to be some kind of DDG remark in one of FF config files thet prevent install proper DDG plugin, deleting ddg xml doesnt help
posted by <hidden> • 1 year and 6 months ago Link
x.15a2
What I'm saying is that the Restore button remains disabled until you remove one of FF's default search engines:
Default:
[https://i.snag.gy/DO1B7V.jpg]
Removed !G:
[https://i.snag.gy/vVdBlk.jpg]
Since DDG is already in the default search list, there is no reason to add it, though you may want to set it to your default search.

If you are seeing results other than I've explained you may want to create a new user profile and try from there.

Thanks!

posted by x.15a2 Community Leader1 year and 6 months ago Link
anonymous
of course I tried also removing all of them, one needs to stay.
posted by <hidden> • 1 year and 6 months ago Link
anonymous
[HOW TO SOLVE]
for future reference, I deleted the search.json.mozlz4 file from my profile folder, that made a rest of my search engine list and the restore button is not grayed out anymore.
posted by <hidden> • 1 year and 6 months ago Link