Autocomplete Uses Wrong Language

<hidden> anonymous
Created: 10 months and 28 days ago • Updated: 10 months and 28 days ago
Does anyone know why DuckDuckGo's autocomplete would assume I speak French?

In settings, I chose American English for my display language. Yet whenever I start typing a search query (in English), autocomplete tosses out suggestions in French, not English, and tacks French endings onto the (English) words I'm writing.

I've used DuckDuckGo for several years and never had this problem in Firefox. Recently I switched to Chrome -- and this problem suddenly appeared. Could Google settings affect my DuckDuckGo autocomplete? I did tell Chrome not to translate French pages for me.

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.


x.15a2
If your DDG language is not set to French, check your OS and\or browser's default language. I set my browser's language to French and the autosuggest results were in French. Returning to English gave English results (following browser restart).
posted by x.15a2 Community Leader10 months and 27 days ago Link
anonymous
Thanks for the suggestion!

Chrome is set to English as well. But I do think Chrome is the source of my problem. I added "Latin" to my list of languages Chrome should not translate, and now DDG autocompletes in French and Latin.

I switched Chrome completely to French; closed the browser; came back in in French; switched default language to English; closed the browser; restarted. This did not change autocomplete. It's still in French (and now Latin).

I also unclicked the "remember results of last search" button in the DDG app settings. This had no result.
posted by <hidden> • 10 months and 27 days ago Link