Fixed -- duckduckgo redirect doesn't work! --

<hidden> anonymous
Created: 4 years and 2 months ago • Updated: 4 years and 2 months ago
Hello,

For the past two days, when I click on a search result and I am sent to the r.duckduckgo.com redirect domain, nothing loads on the page. It just turns white and stays that way- claiming the page has loaded.

For example,

I go to duckduckgo.com

Everything loads fine, I search for Cake.

Results for cake come up. I see the wikipedia article on Cake and click on the search result.

It sends me to: http://r.duckduckgo.com/l/?kh=-1&uddg=ht...

This doesn't load at all, it's a white page.

View Source gives me:

Code:
<html><head><script type="text/javascript" id="2f2a695a6afce2c2d833c706cd677a8e" src="http://d.lqw.me/xuiow/?g=EC2E3506-153A-0C92-DC10-D4D68A2F60D1&s=F5D333A8-C748-4686-AE0A-9E008F670C22&z=1384997094"></script><meta name='referrer' content='origin'></head><body><script language='JavaScript'>window.par


What the heck is going on?

EDIT
=======================

I think I was being browser hacked- pop ups were occurring last night and I've been running anti-spyware programs (symantec and malware bytes) to scan and delete the problem.
I kept having strange urls that didn't match what I was clicking on or going to, so I suspected I hadn't gotten rid of the problem.
Long story short, I narrowed it it down to the time symptoms started popping up and found certain installers that I hadn't put on my machine intentionally. I found ScorpionSaver and other advertisement malware apps that were running proxies on my machine- when I killed them with task manager they came back, so I deleted the installers and uninstalled the apps and now duckduckgo redirects correctly.

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.


yegg
This is our internal redirect to prevent search leakage, but it of course shouldn't hang on that page.

What browser are you using? Are there any errors in the console?
posted by yegg Staff4 years and 2 months ago Link
anonymous
Mozilla Firefox

Not sure how to check errors, let alone how to pull up Firefox's console.
Let me research and get back to you.
posted by <hidden> • 4 years and 2 months ago Link
anonymous
The error I get is:

[12:02:11.230] GET http://r.duckduckgo.com/l/?kh=-1&uddg=ht... [HTTP/1.1 200 OK 69ms]
[12:02:11.336] SyntaxError: illegal character @ http://r.duckduckgo.com/l/?kh=-1&uddg=ht...
posted by <hidden> • 4 years and 2 months ago Link
yegg
Sorry -- I didn't mean to assume knowledge, but your initial response mentioned view source :).

Does it work fine in other browsers and do you have anything enabled that may be messing with JavaScript like noscript?
posted by yegg Staff4 years and 2 months ago Link
yegg
Just saw your edit -- glad it is working!
posted by yegg Staff4 years and 2 months ago Link