XMPP not working ECONNREFUSED

<hidden> anonymous
Created: 4 years and 5 months ago
Hello,

It's been a few days I can't connect to my XMPP account anymore or really randomly.

From my phone (with yaxim) I get ECONNREFUSED. Sometimes it suddenly connects when I change of Internet access.

From my computer I get this on gajim:
06:29:52 (I) gajim.c.connection >>>>>> Connecting to dukgo.com [dukgo.com:5222], type = plain
06:29:52 (I) gajim.c.x.plugin Plugging <common.xmpp.transports_nb.NonBlockingTCP instance at 0x273dab8> __INTO__ <common.xmpp.client_nb.NonBlockingClient instance at 0x273da70>
06:29:52 (I) gajim.c.x.transports_nb NonBlockingTCP Connect :: About to connect to 23.21.227.79:5222
06:29:52 (I) gajim.c.x.transports_nb Plugging fd 12, W:True, R:False
06:29:52 (I) gajim.c.x.idlequeue read timeout set for fd 12 on 30 seconds
06:29:52 (I) gajim.c.x.transports_nb After NB connect() of 41147064. "Operation now in progress" raised => CONNECTING
06:29:52 (I) gajim.c.x.idlequeue read timeout removed for fd 12
06:29:52 (I) gajim.c.x.transports_nb pollend called, state == CONNECTING
06:29:52 (I) gajim.c.x.transports_nb Error while disconnecting socket: Transport endpoint is not connected
06:29:52 (D) gajim.c.x.client_nb While looping over DNS A records: Error during connect to 23.21.227.79:5222
06:29:52 (I) gajim.c.x.client_nb Disconnecting NBClient: Run out of hosts for name dukgo.com:5222. Error for last IP: Error during connect to 23.21.227.79:5222
06:29:52 (I) gajim.c.x.plugin Plugging <common.xmpp.transports_nb.NonBlockingTCP instance at 0x273dab8> __OUT__ of <common.xmpp.client_nb.NonBlockingClient instance at 0x273da70>.
06:29:52 (D) gajim.c.x.client_nb Client disconnected..
06:29:52 (D) gajim.c.x.client_nb calling on_connect_failure cb
06:29:52 (D) gajim.c.connection Connection to next host
06:29:52 (D) gajim.c.connection Out of hosts, giving up connecting to dukgo.com
06:29:52 (D) gajim.c.ged our-show
Args: (<common.connection_handlers_events.OurShowEvent object at 0x1ebed10>,)
06:29:52 (D) gajim.c.ged connection-lost

I have friend who report me that the server is "down". I guess it's possible they have the exact same issue.

Regards

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.


anonymous
I just tried with the login access provided by signing up in this forum, and I tried with pidgin:

(06:48:28) account: Connecting to account cecton@dukgo.com/pidgin.
(06:48:28) connection: Connecting. gc = 0x200dfd0
(06:48:28) dnssrv: querying SRV record for dukgo.com: _xmpp-client._tcp.dukgo.com
(06:48:28) dnssrv: res_query returned an error
(06:48:28) dnsquery: Performing DNS lookup for dukgo.com
(06:48:28) dns: Created new DNS child 4167, there are now 1 children.
(06:48:28) dns: Successfully sent DNS request to child 4167
(06:48:28) dns: Got response for 'dukgo.com'
(06:48:28) dnsquery: IP resolved for dukgo.com
(06:48:28) proxy: Attempting connection to 23.21.227.79
(06:48:28) proxy: Connecting to dukgo.com:5222 with no proxy
(06:48:28) proxy: Connection in progress
(06:48:28) proxy: Connecting to dukgo.com:5222.
(06:48:28) proxy: Error connecting to dukgo.com:5222 (Connection refused).
(06:48:28) proxy: Connection attempt failed: Connection refused
(06:48:28) jabber: Couldn't connect directly to dukgo.com. Trying to find alternative connection methods, like BOSH.
(06:48:28) dnssrv: querying TXT record for dukgo.com: _xmppconnect.dukgo.com
(06:48:28) dnssrv: res_query returned an error
(06:48:28) jabber: Unable to find alternative XMPP connection methods after failing to connect directly.
(06:48:28) connection: Connection error on 0x200dfd0 (reason: 0 description: Unable to connect)
(06:48:28) account: Disconnecting account cecton@dukgo.com/pidgin (0x1b6e030)
(06:48:28) connection: Disconnecting connection 0x200dfd0
(06:48:28) connection: Destroying connection 0x200dfd0
posted by <hidden> • 4 years and 5 months ago Link
jaryd
Weird--I connect with Pidgin just fine. So to clarify, connecting straight to xmpp.dukgo.com is working over a normal connection but not over Tor?
posted by jaryd Staff4 years and 5 months ago Link
anonymous
Sorry for the confusion, I used Tor yesterday to bypass a NAS but it is not related at all with Tor. With or without, if I don't use xmpp.dukgo.com, it works in a really random way (it's definitely not usable).

It seems that changing of connection get me this error easily.

We can make some test whenever you want if you want.
posted by <hidden> • 4 years and 5 months ago Link
jaryd
OK we just moved to a Multi Domain certificate, and changed the A record for dukgo.com back to this server. Hopefully, this should resolve your connection issues. Please let me know if you're still having problems!
posted by jaryd Staff4 years and 5 months ago Link
anonymous
It's been a few days now I'm using dukgo.com normally and everything works perfectly. Thanks for the great service!
posted by <hidden> • 4 years and 5 months ago Link
jaryd
Fantastic! I'm glad to hear that :)
posted by jaryd Staff4 years and 5 months ago Link
anonymous
Huh, I randomly tried the trick from here:
https://duck.co/forum/thread/4833/does-d...

Changing the server to: xmpp.dukgo.com

And now it works fine everywhere. But I wasn't using Tor network and I'm sure it used to work from time to time....

Really random issue...
posted by <hidden> • 4 years and 5 months ago Link