DDG URL parameters not being followed

Duckuser123456 Duckuser123456
Created: 3 years and 11 months ago • Updated: 3 years and 11 months ago
This is so irritating. Yesterday, everything was working fine but now DDG isn't respecting my settings for some reason. I have DDG set as my homepage using URL parameters to control settings (opening a tab also opens to this page). I even tried to reconfigure and copy paste the new listed custom URL parameters but it only follows some of my preferences and not others ( the autosuggest and header behavior in particular). How can I fix this?

This forum has been archived

Thank you all for the many comments, questions and suggestions. Particular thanks go to user x.15a2 for constantly monitoring, replying and helping so many users here. To continue these discussions, please head over to the DuckDuckGo subreddit.


anonymous
I'm having the exact same issue and I've been working on it for way longer than I should be. It seems every once in a while, I get bumped off and have to reset (I wonder who or what is doing that? Windows, Comcast, Duckduckgo???). No problem but today it won't budge. Can someone PLEASE help with this. I want my settings back. I don't want to cloud enter them constantly.
posted by <hidden> • 3 years and 11 months ago Link
anonymous
I can't believe NO one has replied. WTF!!! Could this have been a javascript issue? There has to be someone in this forum that can respond. It couldn't have happened to just two people on the planet. Please help!
posted by <hidden> • 3 years and 11 months ago Link
yegg
Thanks! We're looking into it right now.
posted by yegg Staff3 years and 11 months ago Link
brians
Can you post the url with the settings params you're using?

The url parameters seem to be working fine for me, i.e floating header and disabled auto-suggest:
https://duckduckgo.com/?kac=-1&ko=1
posted by brians Staff3 years and 11 months ago Link
brians
Just to follow up, we did find a case where it's not working. If you have the CloudSave key as a URL param it's not loading it. Working on a fix ASAP, will post when it's live.
posted by brians Staff3 years and 11 months ago Link
brians
Just pushed a fix for the cloudsave 'key' url param. If that was the issue you were experiencing, it should work again now.

If you're still experiencing issues, definitely let me know.
posted by brians Staff3 years and 11 months ago Link
anonymous
https://duckduckgo.com/?kae=c&kz=-1&kp=-... (url param). I'll try the cloud save url...

Thanks yegg and Brians for reply!
posted by <hidden> • 3 years and 11 months ago Link
anonymous
Nope. Cloud url doesn't stick either.

I do not recall ever seeing underneath the url param the json string and underneath that the cookie data. The url param has always worked before. I'm not a techie but I've been all over my computer settings and everything seems the way it was when the url got bumped 8/7. I updated java yesterday after getting bumped. Idk...

If there is any more light you can shed, it would be appreciated. Thanks. Barbara
posted by <hidden> • 3 years and 11 months ago Link
brians
Thank you for posting the full url above. There was indeed another bug and that helped me find it. I have a fix for it and it should be released to the site shortly. Will let you know.

Thanks again for your help + patience while we worked through it!
posted by brians Staff3 years and 11 months ago Link
anonymous
URL parameters still not working. Loading parameters from cloud makes most of them stick but not all. Also, Search Term is showing in tab using Firefox 31 (with Classic Theme Restorer 1.2.3) despite GET Requestd being set to Off.

I swear by DDG rather than Google but this, on top of the major changes to parameters a while ago, is getting quite irritating.
posted by <hidden> • 3 years and 11 months ago Link
brians
We just released another fix. Can you try again and let me know if it is working now?

If not, can you post the specific URL param link you're using that doesn't work?
posted by brians Staff3 years and 11 months ago Link
anonymous
Hi, Thanks for your prompt response. I just tried again and it's still the same. Things changed some time last weekend. Last week everything was fine. I have done no Windows, Firefox or any other software updates during this time.

I am using Windows 7 Home Basic, Internet Explorer 11 and Firefox 31.0 (with Classic Theme Restorer [Customize Australis] Version 1.2.3). I also use Avast antivirus software, Windows Defender, DoNotTrackMe and Adblock Plus.

I always use private browsing and accept session cookies which are deleted at the end of the session. Third party cookies are never accepted.

The symptoms are the same using both Firefox and IE as follows:

* All URL Parameters are ignored.

* Loading settings from the cloud (which are identical to the URL parameters) applies most of my settings but not all. These settings are retained until I close the browser, even if I exit from DDG and then go back to it.

* Most noticeable of the settings that fail, even from the cloud, is the GET request (kg=p), which is set to "Off". If I do a search for, say, "Xmas", the search tab description in both IE and Firefox would now be "Xmas at DuckDuckGo". Before these problems occurred, the tab description was just "DuckDuckGo", i.e. it didn't show the search term, which is what I want.

The URL parameters link is:

https://duckduckgo.com/?ks=s&k1=-1&kg=p&...

I emphasise that these URL parameters worked perfectly last week and have not been changed.

The same settings are used when loading from the cloud (excluding, of course, the "https://duckduckgo.com/?").

I hope this helps and that you can find a solution.

If you need any more information, please don't hesitate to ask.

Regards,

Graham
posted by <hidden> • 3 years and 11 months ago Link
brians
Thank you so much for posting all these details. You helped me find 2 major bugs that are now fixed:
1. We weren't clearing the title of the page for the POST setting, so it was still showing the search term in the browser tab.
2. We weren't correctly parsing the url parameters when the color variable had a '#' in it. So everything after the first '#' was getting lost and not applied.

Both of these fixes are live. I think all of the settings in your bookmarklet URL above are being applied correctly now. Please let me know if you hit any other issues so we can get them fixed.

Thanks again!
posted by brians Staff3 years and 11 months ago Link
anonymous
Hi, I tinkered with my settings again last evening for a while and it's looking like the problem has been solved. I don't know the reason I get bumped every once in a while but I'm more than willing to admit when I was attempting to correct the issue this time that I was omitting some step in the process (as simple as it is to set parameters). I used the cloud save url and I've copied it to a document. I apologize for being huffy and perhaps rude in my second post here...frustration is so unbecoming! I have been using ddg almost since it's inception and I love it. I'm a no-frills girl and how great is it to have a search engine that supports this. Thanks! B-
posted by <hidden> • 3 years and 11 months ago Link